[Nauty-list] Apache Server v Combn.Data.Files

Jim White mathimagics at yahoo.co.uk
Wed Sep 13 17:49:16 EST 2006

Hello Brendan

I've had some curious problems trying to download the 
Latin Square data files from
cs.anu.edu.au/~bdm/data/latin** to my home PC.

First, the trivial one - the file containing the one
and only main class element of order 3 (latin_mc3.txt)
doesn't seem to be there, or is misnamed.

The real problem I have had is with the "gz" files. 

At first, I found my standard (ie: horrid) WinDoh's
standard interface (IE4) was getting itself in a tizz
with these files. It would get the file size estimate
correctly, then it would appear to download normally,
but when it got to 99%, it just kept right on going!

On investigation, I find that it was not saving any
data at all.   This occurred with all 8 or so of those

So I dusted off an old demo program I had of a VB
ftp/http client, and decided to tart it up and see if
I could get around this problem.

As far as I can tell, it appears the ANU server is not
handling "disguised synchronous requests" properly. 
In the http protocol, I should be able to use EXECUTE
for both async and sync calls - if I specify a timeout
of zero, that should effectively be synchronous.

The Apache server in this case appears to be treating
a zero timeout value as an instant timeout, rather
than an infinite one.

When I changed my program to always use non-zero
timeouts, it all worked fine, and I was able to
collect all of the large files.  

Oddly, though, when I retest my program some ours
later, it works on everything BUT the file
"latin_mc8.txt.gz".  I know it worked before because I
have a good copy!  But now that file link gives a "404
Not found" error. (and ditto in IE, I see now)

Now I have all the data, I have no actual problem, but
I thought it would be worth mentioning it in case it
really is a server problem, and not my misguided


Jim White

More information about the Nauty mailing list